Jump to content
Killersites Forums

guys need help with Wampserver


phpboy
 Share

Recommended Posts

i just finished downloading the wampserver

then by typing http://127.0.0.1 ...

that's my problem...

after typing that (supposed to be after typing that will bring me to the wamp server right?)

but what happen is..

there is a prompt that needs user id and password?

what seems to be the problem?

pls help me i gotta need to learn php rushness!

pls reply admin >_<

Link to comment
Share on other sites

  • Replies 106
  • Created
  • Last Reply

Top Posters In This Topic

After downloading WAMP, you installed it, correct? And you ran the program and made sure your server was on before you typed in http://127.0...etc, correct?

 

Stefan has two videos that cover installing WAMP and getting it set up:

 

http://idea22.com/video/details/id/200708285941765250 (part 1)

http://idea22.com/video/details/id/2007082810695178710 (part 2)

Link to comment
Share on other sites

aw, how will i take it on? i mean i double click it (the icon) then an icon occured at the right bottom of my desktop then i lef clck it and i choose put online

 

a prom saying :

 

could not execute menu item (internal error){excepton}Could not perform service action :

The service has not been started

 

pls help thnx

Link to comment
Share on other sites

Hi phpboy, I'm just as new as you r, but I had the same problem just the other day so try this:

 

go to start > All programs > wamp server (click on it) > Start server!

 

a icon will appear in the right corner of your desktop next to the clock, click on it, or right click or left click, untill the menu with localhost on top appears, then choose localhost. let me know if it worked.

Link to comment
Share on other sites

how will i uninstall/diable IIS? it is not included in the link... i install IIS because i'm studying asp and now i'm switching to PHP

 

how?

ty

You can't run both Apache and IIS. You will need to remove IIS from Windows Control Panel.

 

Remove IIS.

Remove WAMP

Reboot

Reinstall WAMP

 

That should do it.

Link to comment
Share on other sites

wow great! i have done removing IIS and now i can malke the wamp online and i can now go direct to my localhost ^_^ tnx for the help guys

anyways, sir stefan how can i make apache run with IIS? i mean running it in different port not on 80 so that i can use IIS and apache at the same time?

i just want to know... ^_^

 

 

again ty for those who post here and i'm ready now for watching those videoes ^_^

Link to comment
Share on other sites

wow great! i have done removing IIS and now i can malke the wamp online and i can now go direct to my localhost ^_^ tnx for the help guys

anyways, sir stefan how can i make apache run with IIS? i mean running it in different port not on 80 so that i can use IIS and apache at the same time?

 

Google it -- there seem to be quite a few articles out there that explain it.

Link to comment
Share on other sites

Just look in the APACHE config files and search for 80. When you find the line that says something like: port 80 ... you just need to change this to port 8080.

 

So when hitting Apache that is set to port 8080, the URL would be:

 

127.0.0.1:8080/yourwebsite/

 

That said, why do you need both running at the same time? Just turn one off when you don't need it.

 

Stefan

Link to comment
Share on other sites

Just look in the APACHE config files and search for 80. When you find the line that says something like: port 80 ... you just need to change this to port 8080.

 

So when hitting Apache that is set to port 8080' date=' the URL would be:

 

127.0.0.1:8080/yourwebsite/[/quote']

 

Or do a google search.

 

Thanks,

 

finally got it working :)

Link to comment
Share on other sites

Ok, i have a further problem to the above.

 

I can get to my localhost. I can even get my database filled. But when I run a site that I have running on an online server, i get a crap load of errors and the page doesn't run properly. Does this localhost server not read thru local files? It almost feels like it can't find some of the files for my includes and its throwing about 10 errors back. Anyone had this issue before?

Link to comment
Share on other sites

<?php

$words = "my my my there are so many words in the sentence";

$result = str_word_count($words);

/* str_word_count is a function for counting the strings */

print $result . "

 

";

$did_send = mail('stefan@killerphp.com','php tutorial',"message.....");

echo "Email send: " . $did_send;

 

?>

Link to comment
Share on other sites

You're right it is your thread. Moosh, kindly start your own thread, please don't hijack another's!

 

Phpboy - to answer your question, php needs to know a SMTP address from which it can send emails.

 

You should have a php.ini file somewhere in your php installation. Look for the following in your PHP.ini file and paste in your isp SMTP address (this is the one you were given by your ISP for entering into Outlook or Thunderbird):

 

[mail function]

; For Win32 only.

SMTP = mail.myisp.net; for Win32 only

smtp_port = 25

sendmail_from= php@home.com ; for Win32 only

Link to comment
Share on other sites

awts, i cant understand sorry....

i have found the php.ini file in a notepad and upon looking at it i see this there:

 

[mail function]

; For Win32 only.

SMTP = localhost

smtp_port = 25

 

is that what your saying? what will i do?

delete it and paste

 

[mail function]

; For Win32 only.

SMTP = mail.myisp.net; for Win32 only

smtp_port = 25

sendmail_from= php@home.com ; for Win32 only

 

pls reply thnx

Link to comment
Share on other sites

; For Win32 only.

SMTP = localhost

smtp_port = 25

 

change "localhost" to your own isp's SMTP address (as tpattison said, it's the same one you enter in your email program)

 

In general, I've had issues setting up the mail() function to send email properly when running on a local server -- I tend to test any mailing functionality from my hosting, where I know they should have it set up properly to start with.

Link to comment
Share on other sites

Usually, you would enter it as your outgoing mail server in Outlook / Thunderbird, Mail.app -- whatever email program you use. If you let me know which program you use, I should be able to help you find it. If you don't use one, I'd suggest doing a Google search for the name of your internet access provider and "SMTP" -- most companies will have it on their website.

 

If you can't figure it out, just skip that part and come back to it later. Or, if you have web hosting, you could upload your files there and mail() should work.

Link to comment
Share on other sites

For Outlook... (this may vary slightly depending on which version of Outlook you have, but either way, you should be able to find this information if you edit your email account details)

 

Keep in mind that I don't have Outlook on this computer, so I'm going from memory here:

 

-- Go to Tools > Email Accounts

-- select the "View or change existing email accounts" option

-- I believe there is a screen that allows you to select your email account, so do that...

-- After you select your email account, another screen should pop up that will allow you to edit your account information

-- in that popup, under "Server Information" there should be a field for "Outgoing Mail Server (SMTP)

-- that is the SMTP address you need.

 

Using that address, you would then edit this line of your php.ini file:

 

SMTP = localhost

 

to use your SMTP address, rather than localhost.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share


×
×
  • Create New...