Jump to content
Killersites Community
Sign in to follow this  
dina

 - BOM characters

Recommended Posts

I went to the old forum to read up on BOM, I followed the link and still don't understand how to resolve it. Can anybody please give me a quick selotion for BOM characters at the beginning of my web page please. It seems to me it is blocking any thing after it cause I'm sitting with a blank page in front of me!:o

 

I have read that people experience this problem if working with php, well I'm working with php if that can help.

 

thank you

Share this post


Link to post
Share on other sites

If you are using Notepad, it may be as simple as making sure you are saving it using "ANSI" encoding during the Save As process, rather than "UTF-8" (there is a dropdown in the lower left hand corner of the save as box, just below "Save as Type"

Share this post


Link to post
Share on other sites

originally I am using notelpad, but I got DWmx demo from a friend so that I can get the feel of it, and still it gave me BOM when I opened it in DW.

 

But I must add, in the mean while while waiting for a reply I went and opened my php & css in notepad and then resave them both under ANSI insted of UTF-8 and the BOM disappear. I then went back and change it back, and as sure as Hell, there they are again.

 

I have manage to get my content on css back on my page, cause I was on the wrong level in my link.

Share this post


Link to post
Share on other sites
I went and opened my php & css in notepad and then resave them both under ANSI insted of UTF-8 and the BOM disappear.

Sounds like that is your solution then -- make sure you are saving them as ANSI rather than UTF-8.

Share this post


Link to post
Share on other sites
great minds think alike, just want to know if I do save as ANSI will it affect my PHP?

 

No, it shouldn't affect your PHP at all (well, with the exception of removing the symbols from displaying of course). It won't change any functionality though.

Share this post


Link to post
Share on other sites

ok thanks Ben, could you then shortly define the diff. between ANSI vs. UTF-8 cause I'm sure I read somewhere that we have to save php files with UTF-8. :/

Share this post


Link to post
Share on other sites

"The first step you will have to take is to give up Notepad. Notepad has a bug (OK, not strictly a bug, but a very undesireable feature). When saving as Unicode (utf-8), it adds a byte-order mark, which is a zero-width space used to indicate the file contents and whether UTF-16 is "little-endian" or "big-endian" (waaay off-topic for this post!). A BOM is not required in utf-8 and should never be used on the web. Notepad will break your utf-8 pages, sometimes to the extent that you will need a hex editor to fix them.

 

If you use a web-friendly text editor then just select utf-8 and save away. You may need to convert older files, and it is best to be consistent and save as utf-8 everywhere. Don't forget that one big advantage of utf-8 is that it is ASCII-compatible, so the transition is easy. "

http://www.webmasterworld.com/forum21/11759.htm

 

That seems to indicate that it is an issue with the way that Notepad saves files... though I can save as UTF-8 in Notepad and it seems to work fine for me, no BOM displays. Odd. The post is old though, so maybe it's no longer applicable.

 

I don't fully understand the difference between ANSI and UTF-8 myself... Basically, it seems like they are different character sets that allow you to save a range of characters, and UTF-8 is preferred, since it can store more characters. Someone may have to help me with me explanation here -- I checked Wikipedia but most of it is very technical and went over my head.

 

The point is, it sounds like UTF-8 is the way to go, maybe just don't use notepad to save the files. I wouldn't usually suggest using Notepad anyway, at least go with a text editor that has tabs and code highlighting and such.

Share this post


Link to post
Share on other sites

Notepad++ is the answer to all your BOM pains :)

 

For some reason, with Dreamweaver (and maybe other editors), the BOM (Byte Order Mark) is introduced when you have not asked it to be... and only on some pages. It's a bug. Problem is, the bug makes your page invalid to W3C standards. The DW validation tool won't pick this up

 

Download and install the free Notepad++.

http://notepad-plus.sourceforge.net/uk/site.htm

 

Whenever the W3C validator throws up the BOM error, just open up the file in Notepad++, click on the 'Format' option, tick 'encode in UTF-8 without BOM' and then save your file. The BOM is taken out and your page is valid again.

Share this post


Link to post
Share on other sites
Guest ashim

That seems to indicate that it is an issue with the way that Notepad saves files... though I can save as UTF-8 in Notepad and it seems to work fine for me, no BOM displays. Odd. The post is old though, so maybe it's no longer applicable.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×