Jump to content
Killersites Forums

PHP display_errors


Recommended Posts

Verified the version of PHP that I am using in MAMP, which is 7.2.10.  Chose the corresponding php.ini doc.  Searched for display_errors and found that it was off.  changed to on.  Saved doc.  turned off Apache server.  Closed MAMP.  Restarted MAMP and server.  Reloaded the php doc for this lesson ch4-lesson-1.php.  Still not showing the errors?!.  What am I doing wrong?

Found a work around on Stackify by pasting in the following code into the PHP doc:

ini_set('display_errors', 1);
ini_set('display_startup_errors', 1);
error_reporting(E_ALL);

This works, but only on a doc by doc basis.

 

Link to post
Share on other sites

Do you think it would help to uninstall, then reinstall MAMP?  Should I maybe switch to using WAMP, or one of the other servers?  Are any of them beginner friendly?

 

(Yeah...guess, using PHP includes would be good practice. LOL.)

Edited by KeithHunt
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...