Jump to content

Cookies and IE7 and IE8


Recommended Posts

I mentioned on the test forum that IE7 with cookies blocked and session cookies allowed does not allow a log in; a message comes up saying that you appear to be logged in but need to enable cookies. You can't do anything which requires to be logged in until you enable cookies and log in again. No big deal because there is an explanation of the problem. The old forum did not have this problem.


I thought I would test IE8 beta 2 but this does allow a log in with cookies blocked and session cookies allowed.


Firefox allows a log in but the options are different - accept cookies "until I close Firefox".


I also wanted to see if IE8 had any problems because it is still causing many people trouble but I can only see one minor one at the moment; Where it says "Write message" next to the post input box the red message "(Required)" is over the top of "Write message".

Link to comment
Share on other sites

IE7 is now letting me log in with cookies blocked but session cookies allowed.


I think I understand now what was happening.


Yesterday and this morning I was having trouble logging into the test forum with IE7 with cookies blocked but session cookies allowed; I got the message " You appear to have logged in successfully, however a cookie has not been set. Please check your settings and if applicable, enable cookies for this website" and if I changed to "accept cookies" it was OK.


Today with the new forum I'm not getting the problem with cookies, but killersites.com is in my trusted sites while killerblogs.com is not. In IE7 I normally have ActiveX disabled so it seems that although the message was about cookies, it may have been the ActiveX setting that was causing the trouble.


I tend to keep ActiveX disabled in IE7 but javascript enabled in FF so that I can test without or with ActiveX/javascript quickly and some ActiveX/javascript effects annoy me, so I use IE7 for pages where I think that will happen.

Link to comment
Share on other sites

Even if you disallow cookies in Firefox, you can enable them per-site via:




Enter the URL of the site you wish to allow cookies and select "Allow".


Alternatively, you can right click on the page you want to allow cookies and select "View Page Info". Next click on the "Permissions" tab and uncheck "Use Default" under "Set Cookies". Finally, make sure the "Allow" radio button is selected.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...