Jump to content


Photo

Could be CSS - background color change not in IE


  • Please log in to reply
7 replies to this topic

#1 jonbey

jonbey

    Member

  • Member
  • PipPip
  • 26 posts
  • LocationEssex, UK.

Posted 19 October 2011 - 04:06 AM

I updated the background using the wordpress background tool for http://www.bumstumsandthighs.com/ and the background shows in Firefox and Chrome but not in IE 8.0.6001

I am guessing that I need to force something in for IE in the CSS manually, but cannot work out what or how. Any ideas?
  • 0

#2 Wickham

Wickham

    Advanced Member

  • Advanced Member
  • PipPipPipPip
  • 1,732 posts
  • LocationSalisbury UK

Posted 19 October 2011 - 08:32 AM

I'm not sure why IE isn't processing the body background. You have a style tag with
<style type="text/css">
body { background-color: #702C53; }
</style>
and it works in Firefox but not in IE, even though it's after the IE conditional comment. I found that if I moved it to the last item before the </head> tag it worked in IE9, perhaps something in the scripts was affecting IE.
<style type="text/css">
/*body { background-color: #702C53; } ......moved down below*/
</style>

<style type="text/css">.recentcomments a{display:inline !
important;padding:0 !important;margin:0 !important;}
</style>

<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}
</style>
 <script type="text/javascript">var analyticsFileTypes = [''];
	var analyticsEventTracking = 'enabled';</script> 

<script type="text/javascript">var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-470187-29']);
	_gaq.push(['_trackPageview']);
	_gaq.push(['_trackPageLoadTime']);
	(function() {
		var ga = document.createElement('script'); 
ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == 
document.location.protocol ? 'https://ssl' : 'http://www') + 
'.google-analytics.com/ga.js';
		var s = document.getElementsByTagName
('script')[0]; s.parentNode.insertBefore(ga, s);
	})();</script> 
<style type="text/css">
body { background-color: #702C53; } /* ..........moved here */
</style>
</head>
I found that even if I added background-color: #702C53; to the ie stylesheet it still didn't work in IE.
You have a real jumble of style tags in the head section, but the style tag with the background should have worked as it was one of the last ones.

Edited by Wickham, 19 October 2011 - 08:39 AM.

  • 0

#3 Eddie

Eddie

    Advanced Member

  • Advanced Member
  • PipPipPipPip
  • 3,618 posts
  • LocationTexas

Posted 19 October 2011 - 09:34 AM

Instead of using background-color, try just background: #702C53;

...and Wickham is right, it's a jumble of codes you have.
  • 0

#4 jonbey

jonbey

    Member

  • Member
  • PipPip
  • 26 posts
  • LocationEssex, UK.

Posted 19 October 2011 - 01:02 PM

Thanks, I will try Eddie's option first, then maybe wonder about the mess....
  • 0

#5 Guest_gwb

Guest_gwb
  • Guests

Posted 03 November 2011 - 06:49 AM

If you want then make external css for your website and use all functions in it.
  • 0

#6 Andrea

Andrea

    Advanced Member

  • Moderators
  • 5,718 posts
  • Facebook:https://www.facebook.com/aandbwebdesignAB
  • LocationSan Antonio, TX

Posted 03 November 2011 - 07:18 AM

If you want then make external css for your website and use all functions in it.


Did you even read what's in this thread or look at the link (and the source code)?
  • 0

#7 Eddie

Eddie

    Advanced Member

  • Advanced Member
  • PipPipPipPip
  • 3,618 posts
  • LocationTexas

Posted 03 November 2011 - 08:33 AM

Did you even read what's in this thread or look at the link (and the source code)?

I'm just surprised that you just don't delete the account along with a couple of others because they have nothing useful to say in regards to other valid users questions.
  • 0

#8 Andrea

Andrea

    Advanced Member

  • Moderators
  • 5,718 posts
  • Facebook:https://www.facebook.com/aandbwebdesignAB
  • LocationSan Antonio, TX

Posted 03 November 2011 - 09:41 AM

I'm just surprised that you just don't delete the account along with a couple of others because they have nothing useful to say in regards to other valid users questions.


You have a point, I just thought I'd give them another chance and hope they figure out the purpose of the forum - or go away on their own.
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users