Jump to content
Killersites Forums

jQuery Question


Recommended Posts

I have a dropdown submenu in the nav bar of my website...when i click on one of them it works fine. When im on the same page as where those links point to they dont seem to work correctly. ex: if i am anywhere else on the website except the portfolio page the links work fine, but when im running the portfolio.php script and i try to click any of the links it just takes me back to the home part of the portfolio page. I will have to post my web address because even im confused about what i just said lol. its imaginationunleash3d .com/new/

 

jQuery was used to make the slide down divs for the submenu

 

just trying to figure out a way to make all links work whether they are for that particular page or not. Its giving me a headache XD.

 

I forgot to mention that im using jQuery .tab() plugin. When i click the link i want it to open that particular tab, which it does, unless im on the page already.

Edited by Archadian
Link to post
Share on other sites

I've played around with this a little, and my best guess is that maybe it's an issue with the tab script itself. This issue doesn't seem to occur when Javascript is turned off, though I'm not sure how much that actually means. I'm assuming you don't have anything PHP related on the page that messes with the URL?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...