Jump to content
Stef's Coding Community
Jsheffers

Z-index problem in IE7

Recommended Posts

I am having trouble getting the navigation to sit on top of my javascript fading images. It works on every browser on the mac. Firefox and opera on the PC. Except IE. www.p y l e r ealty.com

Any help would be absolutely great. It also pushes one of the drop down items to the left.

 

Shane

Share this post


Link to post
Share on other sites

I had the same issue with a Flash movie with an z-index of 100 that covered a drop down menu. Apparently in IE all Active content on a page will always rise to the top, so to speak, including Flash, certain form elements, Java applets, and Active X controls. This means that each of these will poke through layers, and ignore the z-index of other elements.

 

I found a solution for my Flash problem, I suggest you Google javascript issues with drop down menus. Failing that, use Flash for your slideshow and use this work around

http://kb2.adobe.com/cps/142/tn_14201.html

Share this post


Link to post
Share on other sites
Try giving the #navs parent (or it's parent) a higher z-index. Remember, add position relative to any z-indexed element.

 

Thanks that fixed it. Thats weird to because I even ran a script that applied z-index to each element on the page highest numbers for elements at the top then decreasing by 10 and it still wouldn't work. One other weird thing is happening. When you hover over "Buying" the "search the MLS" list item is somehow being pushed over.... It doesn't happen for any other list item...

Share this post


Link to post
Share on other sites
Try giving the #navs parent (or it's parent) a higher z-index. Remember' date=' add position relative to any z-indexed element.[/quote']

 

Thanks that fixed it. Thats weird to because I even ran a script that applied z-index to each element on the page highest numbers for elements at the top then decreasing by 10 and it still wouldn't work. One other weird thing is happening. When you hover over "Buying" the "search the MLS" list item is somehow being pushed over.... It doesn't happen for any other list item...

 

I don't see it - what browser does it occur in?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...