Jump to content


Photo

Can't figure out the parse error


  • Please log in to reply
5 replies to this topic

#1 cowboyandy

cowboyandy

    Member

  • Member
  • PipPip
  • 25 posts
  • LocationWimberley, TX

Posted 17 November 2011 - 03:35 PM

Thanks to this forum, I'm getting better at utilizing css...or at least think I am! I redid some of it, then tried validating, and I keep getting this on validation:

Value Error : list-style-image Parse Error :(http://www.renttexas...lltxflagnav.jpg)

I know this is something simple, but I just can't figure it out. It's the only error on validation, so I'm happy with that - but sure would like to know how this line in my css is incorrect:

list-style-image:(http://www.renttexas...lltxflagnav.jpg);

As usual, your help is greatly appreciated - especially by us novices!

Have a great day, and God bless!

Edited by cowboyandy, 17 November 2011 - 03:53 PM.

  • 0
The Ole Cowboy
Gittin' Older, But Not Agin'!
The Ole Cowboy - was hacked, haven't reuploaded yet

#2 Ben

Ben

    Administrator

  • Administrators
  • 5,643 posts
  • LocationChico, CA

Posted 17 November 2011 - 04:05 PM

I believe you are missing the "url" portion: http://www.w3schools...style-image.asp

For example:

ul
{
list-style-image:url('icon.gif');
}
  • 0
Benjamin Falk
Falken Creative : Twitter

#3 cowboyandy

cowboyandy

    Member

  • Member
  • PipPip
  • 25 posts
  • LocationWimberley, TX

Posted 17 November 2011 - 04:49 PM

I believe you are missing the "url" portion: http://www.w3schools...style-image.asp

For example:

ul
{
list-style-image:url('icon.gif');
}

Hey, Ben!

I had that originally, but it gave me 3 errors...I'll try it again and see what happens.
  • 0
The Ole Cowboy
Gittin' Older, But Not Agin'!
The Ole Cowboy - was hacked, haven't reuploaded yet

#4 cowboyandy

cowboyandy

    Member

  • Member
  • PipPip
  • 25 posts
  • LocationWimberley, TX

Posted 17 November 2011 - 04:55 PM

I believe you are missing the "url" portion: http://www.w3schools...style-image.asp

For example:

ul
{
list-style-image:url('icon.gif');
}


Yuppers! Here's the change:

list-style-image:url (http://www.renttexas...lltxflagnav.jpg);

Now three errors:

Value Error : list-style-image url is not a list-style-image value : url
Parse Error (http://www.renttexas...lltxflagnav.jpg);
Parse Error [:#000000; vertical-align:middle; text-align:left; } /*--content--*/ #propdetails] Have no idea why this one appears with the above change!

Any ideas?
  • 0
The Ole Cowboy
Gittin' Older, But Not Agin'!
The Ole Cowboy - was hacked, haven't reuploaded yet

#5 Ben

Ben

    Administrator

  • Administrators
  • 5,643 posts
  • LocationChico, CA

Posted 17 November 2011 - 05:07 PM

There can't be a space between "url" and the opening "(".
  • 0
Benjamin Falk
Falken Creative : Twitter

#6 cowboyandy

cowboyandy

    Member

  • Member
  • PipPip
  • 25 posts
  • LocationWimberley, TX

Posted 17 November 2011 - 05:26 PM

There can't be a space between "url" and the opening "(".


:clap:

I knew it had to be something simple...why didn't I think of that? :bash:

Thanks Ben!
  • 0
The Ole Cowboy
Gittin' Older, But Not Agin'!
The Ole Cowboy - was hacked, haven't reuploaded yet




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users