Jump to content
Stef's Super Nerd Coding Community
Sign in to follow this  
virtual

Disable top level link

Recommended Posts

Hi All,

 

I have run into this problem several times with Wordpress and never really found the solution.

 

I do not want the top level links with a drop downs to be a link to an actual page. So to remedy this my idea was to not create a page but use a custom link with # instead of the page name e.g. http://mysite.com/#/

 

This works fine as long as I am not on the home page, which opens to http://mysite.com/. On the home page I now have both links highlighted as active. How can I achieve this without the second link showing active?

 

Thanks

Share this post


Link to post
Share on other sites

I thought I had figured it out, but I was wrong.

 

Anyone have any ideas??

Edited by virtual

Share this post


Link to post
Share on other sites

So I found it on a wordpress.org forum:

 

To disable any parent item in WordPress 3.0 Menu:

 

1) Be sure you have activated the link target in the options menu on your menu page

2) Insert a custom link with no matter what link

3) select the just created custom link. click on the dropdown link on the top right side.

4) delete the link from the URL field

5) done

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...