Jump to content
Killersites Forums

Where is WAMP?


Virtual-Instructor
 Share

Recommended Posts

I am wondering if anyone can point me to a valid WAMP download page. http://www.wampserver.com/ is the only thing that I can find and its in like French or something. I am looking for the same WAMP 5 Server that is shown on Video 3 of the PHP basics videos. I've conducted several searches and I keep coming up with the same thing. I would like to make sure that I am understanding this materal properly and would like to do the majority of testing on my local machine vs spending the money on a web server and burning time on that server trying to learn. Any advice here is helpful.

Link to comment
Share on other sites

Ok so I am noticing my first issue. I have installed WAMP and have been running through the steps as the video plays. During the explination of WAMP I opened my www folder and instead of having all of the folders and documents that are in the video show up in the folder I only have two. index & testmysql . In addition I can't seem to get wamp to start. When I type in the 127.0.0.1 address into my browser I get the Error 404. I have tried starting the services with no success. Any help here is appriciated.

Link to comment
Share on other sites

In regards to starting WAMP:

 

-- WAMP needs to be running for you to test PHP files. You need to start WAMP like you would any normal Windows program, by running the executable. You can find it (assuming you installed to the default location) in C:/wamp/wampmanager.exe. It also installs a shortcut in your start menu under "All Programs" > "Wamp Server" > "start WampServer."

-- If that program is running, there should be a small icon (it looks like a gauge) in the bottom right corner of the taskbar by your system clock. You can left click on that, and a menu should appear that looks something like the first image on this page: http://www.wampserver.com/en/presentation.php. The bottom-most item should be "Put Online" (or "take offline" if it is already running.) If you click "Put Online" and it generates an error, first select the option from the menu called "Start All Services" and then "Put Online."

-- From that menu in to taksbar, you can open up "localhost" (also known as 127.0.0.1) in your browser and the "www directory" where your php files should be stored.

-- To shut down the server once you are done with it, you can left click on the gauge icon and select "Take offline" or right click and select "Exit" to close the program completely.

 

In regards to the files you are expecting:

 

-- Are you talking about the files within your C:/wamp/www folder? By default, it only comes with one or two files in that location. You would need to create your own folders/files there. What exact video are you on/what time in that video shows the files you are talking about? Those files may just be left over from previous projects the person who recorded the screencast had done.

 

-- If you're talking about this video: http://killerphp.com/videos/getting_setup_for_php/getting_setup_for_php.html keep in mind that the file structure that Stefan is showing you actually comes from XAMMP, not WAMP. XAMMP is slightly different from WAMP, and has a slightly different file structure, but both work fine, and both are easy to use. My instructions above should get you started.

Link to comment
Share on other sites

Ben as always I appriciate your input and all your great help.

 

Ok so now that I have been able to turn on the services and Put Online I'm now getting an error "Unable to display web page". I did some exploring and noticed that no matter what I do, on Apache the "Start/ Resume Service" option is always visible instead of subdued. I tried the "Test Port 80" function and found that it is being used by Skype. Is there a way that I can change the port that Apache or Skype uses? Because of the work that I do for my online community (which is really why I'm learning all this) my Skype is critical to what I do, but then again so is the web site that I am trying to develop. So I guess what I'm asking is how do I mannage my ports so that I don't loose anything and still come out with all my services working.

 

Allow me to take a moment to inqure XAMPP. I toyed around with this program briefly when I started working with MySQL (which lead me here). I like to keep my options open. If I install XAMPP on my computer will it cause a conflict with WAMP? Furthermore, if you had to choose one or the other; which would you most recomend. Keep in mind that my top priority is efficency.

Link to comment
Share on other sites

I believe you should be able to follow this guide to change the port number: http://www.brucerick.com/changing-wamp-2-1-port-from-80-to-81-or-other-port/. Searching for "change wamp port" should give you some alternatives as well.

 

I also read (on the XAMPP site) that you can modify Skype to resolve the issue:

 

Go in Skype to Actions --> Options --> Connection --> remove the check mark at "use port 80 for an alternate port" and restart Skype. Now it should work.

I'm not sure if this advice is still accurate, but it might be something to check.

 

As far as I know, you can install both XAMPP and WAMP at the same time. I imagine that trying to run both programs at the same time will cause issues though. Personally, I like WAMP better, but that's mostly since that is what I've always used. As far as I know, both are easy to use. Once it's set up once you shouldn't need to mess with it any more.

Link to comment
Share on other sites

Ben thanks for the help, again...... I know I must sound like a royal pain but I really appriciate all the help. The link that you sent me to had pretty straight forward instructions. However yet again I think I'm missing something. I was able to accomplish steps 1 - 3. However when I tried to accomplish steps 4 - 7 I hit two snags. First, in my WAMP root folder I was unable to locate the "wampmanager.ini" file, it simply isn't there. I thought that maybe it was stored in another location, but I didn't see it in any of the other files. I have 4 individual "wampmanager" files in the root WAMP file. One is a CONF File, one is an application, another is Configuration Settings and the last is the TPL file.

 

When I couldn't find the ini file I thought that maybe this was just an update vs an old post situation, so I skipped ahead to step 7. Here I was unable to find the local host parameters lines. There are many headings such as [services], [Messages], [startupaction] and the like. It is entirely possible that because of my inexperiance here I am just missing it because I don't know where to look. Any direction that you can provide here is appriciated.

Link to comment
Share on other sites

That link was posted in April 2011, so I'm pretty sure it is up to date.

 

In regards to step 4, I'm pretty sure the file is there? When I check my local copy of WAMP (C:/wamp) I also have four "wampmanager" files -- an .exe, a .conf, a .tml and a .ini. I think the "configuration file" is the one you need.

 

If you right click and open the files you need in Notepad++, you can do a search to find the exact lines you need. Just use Search > Find.

 

(assuming you are changing to port 81): In wampmanager.ini, I think you'll need to change lines 280, 281 and 384 (change "http://localhost/phpmyadmin/" to "http://localhost:81/phpmyadmin/")

 

In wampmanager.tpl, it looks like the only lines you need to change are lines 120 and 121, which is just under the "[Menu.Left]" header.

Link to comment
Share on other sites

Ok, well thanks to your help Ben I was able to find the needed information and make the changes that were called for in the link that you directed me too. I actually did not attempt to change the Skype settings as I would have lost the current connection and I have be recieving this file for more than 4 hours. After making the changes to the files for Port 81 I did see some success. My WAMP Icon in the system tray is now green and the "Start/Resume Service" option is subdued and the "Stop Service" is now visable; so deffinate progress there, :D:clap: so thanks for that.

 

I'm still trying to figure out these basic items that seem like they should be pretty straight forward. :unsure: While the Wamp Icon is green I'm still getting the HTTP 404 Not Found Error. Although I still consider this to be progress since previously it said Unable to Display Web Page, it now says that the web page cannot be found. Not sure if this is deffinative progress, but I'm sure that it is still a step in the right direction. My thought (and I could be wrong here) is that there is still a configuratioin issue at hand that I'm not picking up on. Could it be that its simply not looking in the right place? It almost seems that its not finding the index. :raised: I went back through the video 4 in the PHP Basics file and I noticed a difference in the installation. In the video it asked Steph specifically where the idex was; yet during my installation it did not do that, it only asked me what my default browser was. Could this be at the heart of the problem that I am having.

 

I am eager to move on thorugh the video series but I want to make sure that I am getting the same results on my machine that Steph is getting in the video. Since I am not willing to pay for a web hosting account until I have the web site at least 70% finished, running it on my own machine is the only option that I have for testing and development.

 

If I haven't said it yet, I want to thank you for all the help that you are giving me. Even though its slow, I still feel like I'm learning something.

Link to comment
Share on other sites

My WAMP Icon in the system tray is now green and the "Start/Resume Service" option is subdued and the "Stop Service" is now visable; so deffinate progress there, :D:clap: so thanks for that.

Good to hear. That should indicate that WAMP is running successfully now.

 

In the video it asked Steph specifically where the idex was; yet during my installation it did not do that, it only asked me what my default browser was. Could this be at the heart of the problem that I am having.

That shouldn't matter.

 

What is the exact URL you are trying to use to access localhost? Are you trying to access localhost by left clicking on the WAMP icon in the taskbar and selecting "Localhost"? Clicking that option should open localhost in your browser, assuming you made the wampmanager.conf/.ini file changes.

Link to comment
Share on other sites

*Facepalm* :huh: I am such an idot. I think I'm getting somewhere now. I was typing in http://localhost . When I added :81 I immediately got the WAMP page. It looks different than the one in the video, but I'm pretty sure that this is what I'm after. So I think that this one is wrapped up. Sort of......

 

Many thanks :clap: to Ben for all his help to date :clap: . I really appriciate the guidance.

Link to comment
Share on other sites

You are absolutely correct Ben. I'm sure that this one will be simple for you. While going through Video 7, I was actually typing out the same code that was on the video making slight alteratioins in the strings (sorry <_< , the whole Hello World thing is worn out). So about mid way through the video (around 8 min 33 sec on the timeline) Steph starts going into the Projects Files which I found, however mine were empty as I had not yet created any files. I created a file, and saved the .txt document that I was working on as the video played to that file. The file showed up under my projects. However Steph never explained how to view the txt document that you were working on. I thought that this might be as simple as clicking in the document, alas the page is still showing up as a txt document. I assume that I have simply saved it or stored it incorrectly. Any ideas?

 

If you would like me to post the code I will be more than happy to.

Edited by Virtual-Instructor
Link to comment
Share on other sites

  • 2 weeks later...

Sorry guys I just wanted to add a quick note. What I did for my skype problem is just shut skype off then turned on wamp then turned skype back on. That way every thing is the same when I work through php tutorials. Again sorry for the interruption in your conversation.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...