Jump to content
Lizard Wizard Coding Club

Cant install new plugins....


Recommended Posts

hi everyone,

 

i have been trying to install some new plugins in my wordpress blog and i keep getting the following error....

 

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/elecsmar/public_html/wp-admin/includes/class-pclzip.php on line 2683

 

is this something todo with the permission on the files in the server or has something gone drastically wrong???

 

Any help would be fantastic :)

 

cheers rusty

Link to post
Share on other sites

How large is the zip file you are trying to upload? Based on the error message, it looks like your server may not have enough memory (to be clear, I'm not talking about disk space, but temporary memory) to unzip the zip file correctly. See http://drupal.org/node/76156 for a bit more explanation of the error.

 

You may be able to fix it by adding

 

ini_set('memory_limit', '32M');

 

to your theme's "functions.php" file. If that doesn't work (it may not), you either will have to unzip the plugin and upload it to the server manually, or talk to your web host about potentially increasing your memory limit.

Link to post
Share on other sites

heya,

 

yeah the zip is just 500k its not big but it looks like it is exausted. but its at 32....... can you get it to be any bigger through talking to the provider? I ve emailed the provider but being australian service you wont get answered for a day or two :(

Link to post
Share on other sites

heya peoples,

 

here is the reply i got from my isp :)

 

Hello,

 

Thank you for your email.

 

Please follow these steps below:

 

1. Create a php.ini file in the directory where the settings need to be changed (wp-admin). This file can just be an empty text document.

2. Insert the configuration value you need to change. This is done ONE PER LINE.

 

 

memory_limit = 128M

 

 

3. Save the php.ini file and make sure it is in the appropriate directory where the permissions need to be changed.

 

You can verify that the settings have changed by running a PHP Info. To do this, create another empty file and call it info.php. Put the following into that file:

Link to post
Share on other sites

heres the link to my site My link to my stuffed website

 

hi everyone,

 

i thought i wouldnt open another topic but this is continued on from the above topic.

 

the above mentioned did work very well :) But i went to add a plugin from google for the analytics stats and it wiped my supercache!!!

 

i still have all my posts and the page still comes up, but when i try to access the homepage or click on the logo a message of " required link or changed or deleted" . i have no idea how to fix this and am not sure what has happened......

 

the google plugin installed the track data into the header php file.........

 

if anyone has had this happen to them please let me know how to fix it... anyones help would be fantastic :)

 

cheers rusty :)

 

the link to what i am getting is here.....

Link to post
Share on other sites

My initial impression is that this has nothing to do with the plugins (unless by accident) but more due to the fact that you are using a template theme, and the template is expecting a backlink back to WebsiteTemplates.bz to appear somewhere in the page. Adding the link back in, as the error message at the bottom of the page shows, will probably fix this error.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...